Would you say Triumphs are reliable? - Page 3
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32
  1. #21
    The "Friends" of Officer Frank Poncherello Bad Santa 1050's Avatar
    Member #
    289
    Join Date
    Apr 2007
    Location
    Lake Macquarie, NSW, Australia
    Posts
    6,173
    Now over 106,000+ miles and still going strong.

    I'd still consider Triumph Speed Triples to be reliable - provided they are at least given basic care and maintenance.


    Sent from my SM-G960F using Tapatalk

  2. #22
    The "Friends" of Officer Frank Poncherello BUCKET's Avatar
    Member #
    33
    Thanked
    17 times
    Join Date
    Jun 2006
    Location
    Gympie,QLD,Australia,YOU KNOW IT!
    Posts
    23,268
    ^ c r i v e n s !
    I like shiny things.

  3. #23
    The "Friends" of Officer Frank Poncherello dr_gallup's Avatar
    Member #
    18
    Join Date
    Jun 2006
    Location
    Upstate SC
    Posts
    4,203
    My '83 VF750F had 3 cams replaced under warranty.

  4. Remove Advertisements
    TheSpeedTriple.com
    Advertisements
     

  5. #24
    Chicken Strips Trumpets's Avatar
    Member #
    4355
    Join Date
    Oct 2011
    Location
    Caterham, Surrey, Blighty
    Posts
    189
    Going back some years I had a Kawa Gpz305 which lunched on ignition units with alarming regularity in the first year of ownership from new, so fortunately didn’t cost me a penny, just inconvenience. That was followed by a z750 turbo which had a fuel injector give up. It got me home running on 3.
    I’ve had two Triumphs to date, the first a ‘97 T595 tona dumped me in the middle of nowhere when the ignition relay threw in the towel. Easy fix once I got it home. The ‘10 S3 also dumped me in the middle of a different nowhere when the reg/rec called it a day but that too was an easy fix after some basic fault finding. I never go out on it expecting a breakdown, I think they’re pretty reliable.

  6. #25
    Noob! Red5's Avatar
    Member #
    20843
    Join Date
    Aug 2019
    Posts
    13
    Well as of this morning I may be somewhat biased when answering this question. Rode to work, look down and hear a lot of bubbling sounds with the motor off. Then it spit out the coolant on the ground next to me. Mine is an 07 Speed Triple.

    Guessing that i need a water pump? Can you rebuild these pumps?

  7. #26
    The "Friends" of Officer Frank Poncherello Bad Santa 1050's Avatar
    Member #
    289
    Join Date
    Apr 2007
    Location
    Lake Macquarie, NSW, Australia
    Posts
    6,173
    I'm betting you that your water pump is fine, and that you or someone has recently topped up your coolant, particularly the overflow reservoir under the seat, or the weather has started getting warmer.
    Mine has done the symptoms you describe since new. In fact all my 955cc/1050cc Triumph triples I've owned have done that.

    If the coolant is topped/filled to the specified levels, the bike will spew out coolant until it reaches it's happy point level that it likes - which is less than the specified full level.

    Personally I wouldn't be concerned.
    Unless you're hearing noises from the water pump and the motor is overheating consistently, the symptoms you described are normal Triumph 955/1050 triple family behaviours.

    Sent from my SM-G960F using Tapatalk

  8. #27
    Noob! Red5's Avatar
    Member #
    20843
    Join Date
    Aug 2019
    Posts
    13
    Quote Originally Posted by Bad Santa 1050 View Post
    I'm betting you that your water pump is fine, and that you or someone has recently topped up your coolant, particularly the overflow reservoir under the seat, or the weather has started getting warmer.
    Mine has done the symptoms you describe since new. In fact all my 955cc/1050cc Triumph triples I've owned have done that.

    If the coolant is topped/filled to the specified levels, the bike will spew out coolant until it reaches it's happy point level that it likes - which is less than the specified full level.

    Personally I wouldn't be concerned.
    Unless you're hearing noises from the water pump and the motor is overheating consistently, the symptoms you described are normal Triumph 955/1050 triple family behaviours.

    Sent from my SM-G960F using Tapatalk


    Thank you! I think that you are correct. I heard this sound sand it spewed out a bit of fluid. Now when I went back out the coolant level is correct. Road it around and let it get hot and it isn't leaking. I take back my previous post. I'm beginning to really like this bike a lot.


    Can anyone tell me what this sounds like? It happens about 30 seconds after I stop riding the bike.


  9. #28
    The "Friends" of Officer Frank Poncherello crashmasterd's Avatar
    Member #
    59
    Thanked
    2 times
    Join Date
    Jun 2006
    Location
    Washington State
    Posts
    31,779
    Quote Originally Posted by Red5 View Post
    Can anyone tell me what this sounds like? It happens about 30 seconds after I stop riding the bike.


    It's transmitting all the information it's collected on you to the mother ship. Expect anal probing to commence soon.


    Nah, that's normal with the new fuel injection. I'm not sure what it's doing but my Street Triple did that every time from the day it was new.
    Quote Originally Posted by Bad Santa 1050 View Post
    Just when you think it can't get worse, Crash comes along and informs you that not only is the glass not half full, but it is stolen and contains a mix of horse semen, urine, laxative and viagra, right after you swallowed a mouthful...
    Quote Originally Posted by Joe Houle View Post
    ...no ink and going baconless on your bacon cheeseburger is about the most rebelious thing you can do these days.

  10. #29
    The "Friends" of Officer Frank Poncherello dr_gallup's Avatar
    Member #
    18
    Join Date
    Jun 2006
    Location
    Upstate SC
    Posts
    4,203
    My '06 doesn't sound like that.

  11. #30
    The "Friends" of Officer Frank Poncherello Bad Santa 1050's Avatar
    Member #
    289
    Join Date
    Apr 2007
    Location
    Lake Macquarie, NSW, Australia
    Posts
    6,173
    Quote Originally Posted by dr_gallup View Post
    My '06 doesn't sound like that.
    Likewise.

    Sent from my SM-G960F using Tapatalk

 

 
Page 3 of 4 FirstFirst 1234 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 6 New Triumphs eh?
    By Redletter in forum General Discussion
    Replies: 27
    Last Post: 11-10-2014, 06:35 PM
  2. 2015 triumphs
    By dpelt73 in forum Triumph News
    Replies: 12
    Last Post: 08-10-2014, 08:14 AM
  3. New To Triumphs
    By triplers in forum Project garage
    Replies: 0
    Last Post: 06-09-2013, 06:56 PM
  4. A lot of Triumphs on the road!
    By Kafn8td in forum General Discussion
    Replies: 7
    Last Post: 10-01-2012, 08:55 AM
  5. Looking for reliable shop in Thousand Oaks area
    By Night Train in forum Speed Triple 1050 05-10/11
    Replies: 4
    Last Post: 12-22-2007, 10:43 AM