2016 speed triple R brembo front brakes spongy
Results 1 to 5 of 5
  1. #1
    Noob! Clint's Avatar
    Member #
    21279
    Join Date
    Jan 2020
    Posts
    2

    2016 speed triple R brembo front brakes spongy

    Hi all,
    Just bought a 2016 speed triple R and I'm having problems with the front brembo brakes, I'm quite disappointed to be honest with you because they are supposed to be some of the best brakes around but mine is like squeezing a wet sponge, it's only done 5000 unabused miles. The pads have plenty of meat on them and I have bled the system at the callipers and the lever (3 times) it feels great for a while then over night the spongy feeing returns, I've tried trying the lever back and I've checked every junction and no leaks so I'm at my wits end with it so any advice would be greatly appreciated
    Cheers

  2. #2
    The "Friends" of Officer Frank Poncherello Avi8or's Avatar
    Member #
    13
    Join Date
    Jun 2006
    Posts
    5,249
    I solved the problem by going to a larger diameter master cylinder. YMMV.

  3. #3
    Chicken Strips Oahu Triple's Avatar
    Member #
    1795
    Join Date
    Jun 2009
    Location
    Honolulu
    Posts
    193
    -you only live once and I feel like I'm running out of time...

  4. Remove Advertisements
    TheSpeedTriple.com
    Advertisements
     

  5. #4
    Noob! Party Marty's Avatar
    Member #
    7009
    Join Date
    Jun 2013
    Posts
    5
    I have a 2017, that I have had since new, and agree with you that the brakes are not as sharp as on the 08 that I used to have. Maybe it's me but I could swear that the 08 brakes were better and almost lethally strong. I put the 2017's spongy feel down to the ABS system. There is nothing really wrong with the brakes but i'll try a larger master cylinder. The bike comes stock with a "16", so where do you go from here? There are a lot of Brembo options.
    Does anyone have any suggestions?

  6. #5
    The "Friends" of Officer Frank Poncherello Chewie.'s Avatar
    Member #
    5
    Join Date
    Jan 2006
    Location
    Melbourne, Victoria Australia
    Posts
    11,679
    Have a look at the thread on Triumphrat (see post#3 above by Oahu Triple). This thread has been going on for a long time. I have not followed it closely so I'm not sure if there is a definitive answer. The Brembo brakes on my 2010 are sensational and I believe the 11-15 brakes are also great. I think the problem started in 2016, so I doubt ABS is the cause as it has been around from before 2016.

    the 05-early 06 models had a similar problem with their Nissin brakes. The fix for them was either a larger diameter MC or caliper pistons out of the late 06-07 models.

    i would definitely start by reading the Triumphrat thread from start to finish.
    John







    "I haven't shot anybody since 1992...and even then I didn't do it!" - Mark 'Chopper' Read

 

 

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •