06 S3 intermittent rough idle/misfire - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    Chicken Strips Duffman's Avatar
    Member #
    5001
    Join Date
    Apr 2012
    Location
    Gardner MA
    Posts
    243
    Quote Originally Posted by turboz View Post
    I've been having a similar issue for some time now. So with my 2006, I have the famous intermittent "RPMs drop/bike nearly stalls" when I pull in the clutch and start slowing down. Also, it takes a good 3-5 seconds of cranking to get it started. Once started, the bike misfires with any throttle input and there seems to be an abundance of condensation coming from the exhaust. Once at operating temp, it starts and runs strong. Just performed an oil change and there does not appear to be any coolant contamination in the oil. Also did a compression test and all cylinders are strong, PSI wise. The difficult cold starts led me to believe that valve clearance would be the issue, but all were within spec. A few exhaust valves were at .30mm, so on the loose side, but within spec.

    So far I've tried a new battery,checked battery terminals for corrosion, checked fuses, replaced complete throttle body assembly/tps/iscv, tried stoltec grounding cables, new plugs, checked all vacuum lines and throttle body boots, checked valve clearance, checked headstock wiring, tried several tunes and have performed the 12 minute tune more times than I can count. When I set the TPS and reset adaptions, it'll be within spec one day- go check it the next and the voltage has changed..... I'm running a mosfet R/R and I replaced the stator with a unit from Rick's motorsport a few thousand miles ago.

    The fact that my problem has persisted over several years has me ready to sell the bike...I hope you find a remedy, and if you do- please update your post to help people troubleshooting in the future!
    So update.

    I finally got my cable in from Lonetec and got tuneecu fired up on my ancient PC and went through the bike that way. I looked at the fuel map and things seemed fine. actuated the Idle stepper, heard noises, then reset adaptations. The bike seems to run much better now, and hasnt hiccuped or almost stalled once. I am unsure as to why this might have fixed things, maybe a runaway adaptation left one of the long term fuel trims way off around idle. we will see how it goes!

  2. #12
    The "Friends" of Officer Frank Poncherello 2doggs's Avatar
    Member #
    6189
    Join Date
    Jan 2013
    Posts
    6,690
    I hope it solves the issue. Not to rain on your parade, but when my stepper motor was going bad I would reset the adaptives and TPS and everything worked fine for about 150 miles. Next time I went out to start it, same idle/stall issues. Reset TPS and adaptives again and everything worked fine. I suggest a test ride close to home each time before any long runs. Just 20 feet forward in 1st then engage the clutch and you’ll know if you need another reset. It’s what I did for over a year before finally bringing it to the dealer.


    Sent from my iPhone using Tapatalk
    Originally Posted by m4ppy
    I have always ridden Aprilias and Ducati bikes, but after years of failing electrics and parts failing off I moved over to Triumph.

  3. #13
    Noob! turboz's Avatar
    Member #
    8090
    Join Date
    Jan 2014
    Posts
    5
    Quote Originally Posted by Duffman View Post
    It sounds exactly like what I am going through. I have an 08 motor in mine and I think, but don't know for sure that Triumph sorted out the R/R in that year.

    I am with @2doggs, I think it's a TPS issue, a software issue, or a vacuum issue.

    What are you running for plugs? I have the NGK CR9EKs I think, but I was told that those are too cold. maye someone with some better plug knowledge can chime in.

    What do you have done to the bike otherwise? any exhaust mods? or blocked off SAI? I have a hunch the dealer remapped my bike to a bone stock tune, which took care of the initial cold start issue but this problem is still prevalent. I will update with more info when my Lonetec cable comes in and I am able to start really diaging stuff.
    So the problem originated when I had a MiVV GP slip on (with arrow low tune) along with a BMC air filter, SAI block off, mosfet R/R and Rick's stator. I went ahead and swapped the entire throttle body assembly with TPS & everything installed and the problem continued. Unless I was extremely unlucky to have two TB assemblies with bad IACV or TPS, I figured I could rule TPS/IACV out as the culprit.
    I had the Iridium NGK's (heat range 9) installed, but recently swapped them with CR8EKs.
    Just recently put the TORS cans back on and loaded the correct tune even trying a O2 sensor delete map.....no luck. Even swapped out the coils and the issue continues....
    The really irritating thing is that the bike starts up pronto after resetting adaptions and running a 12 min tune. A few hours later it's back to the issue.

    Has anybody thoroughly checked the grounding points on an S3? is there a grounding point on the frame or bottom of the motor? I know I had that issue on my thruxton years ago, checked a ground that ran to the bottom of the motor and it cleared up the issue.

 

 
Page 2 of 2 FirstFirst 12

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •