Triumph Speed Triple Forums banner
electrical
1-5 of 5 Results
  1. Trouble-shooting
    I think it may be the starter motor but before dropping 200 on a new one want to get everyone's opinion. Battery is new and retested, all good It's Charging Battery is 12.88 at rest 14+ when running Here are the symptoms Starter turns but sounds like the gears pop in and out every few...
  2. Trouble-shooting
    Just purchased a 99 S3 and have two electrical issues: 1. When the bike is on I have a regular beam of light out of the left headlight, but the right one has a tiny bit of light coming from the bottom of the housing. Is that how it's supposed to be, or should they each be putting out an equal...
  3. General Discussion
    Hello. I have had my 07 S3 for a year and love it, It has been completely reliable until yesterday. I was on a ride in the mountains and these are the symptoms as best as I can remember, Happened pretty fast and was a bit of a holy **** moment. First the bike began to loose power and I...
  4. Speed Triple 1050 05-10/11
    Right guys, I've done a little searching and have seen a few suggestions, but was hoping someone with some knowledge could comment on here help me out. I've a 2009 Speed Triple I noticed the other day that the Indicators/Horn/Brake light didn't work when i tried to turn them on. The...
  5. Trouble-shooting
    Hi guys, hoping someone might be able to shed a little light on a problem i have with my 2005 speed triple 1050 - I live in Australia and the bike has this overheating problem due to the cooling fan not always activating when it is supposed to. It always follows the same pattern - when in...
1-5 of 5 Results
Top