Triumph Speed Triple Forums banner
starting
1-6 of 6 Results
  1. Trouble-shooting
    I'm having starting issues and can't seem to figure out what the culprit is. I put in a new stator (2nd one so far at 54K miles) and the R/R is a FH014AA I put in about 2-3 years ago when the last stator cooked. I also did the 10ga wire upgrade with a 30A in-line fuse, which wound up melting...
  2. Trouble-shooting
    I think it may be the starter motor but before dropping 200 on a new one want to get everyone's opinion. Battery is new and retested, all good It's Charging Battery is 12.88 at rest 14+ when running Here are the symptoms Starter turns but sounds like the gears pop in and out every few...
  3. Speed Triple 1050 11-
    Okay running out of ideas, my 2013 model wont fire. Turns over but no bang, been right through it, full service inc new plugs just churns and churns. It was in storage while I moved house for 4 months, so drained off fuel put fresh in she ran badly, full service started once and went for a...
  4. Trouble-shooting
    [email protected] My 2006 Speedie has opted to embrace its British heritage and puzzingly will not start now. I suspect that it's either the [email protected] sprag clutch or the rectifier. Reading this and this tells me that I'm the right track. The symptoms as of now: The bike has full battery power. When clicked...
  5. General Discussion
    Hello. I have had my 07 S3 for a year and love it, It has been completely reliable until yesterday. I was on a ride in the mountains and these are the symptoms as best as I can remember, Happened pretty fast and was a bit of a holy **** moment. First the bike began to loose power and I...
  6. Trouble-shooting
    My 06 Speed has a starting problem. When I turned on key yesterday I didn't hear fuel pump come on and the bike would not start. I had just driven it. I pull the engine fuse, it was fine and when I put it back it arced (key was off) and fuel pump came on and bike started. Turned key off and it...
1-6 of 6 Results
Top