Triumph Speed Triple Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Long story short...
I bought a used 2001 Speed Triple with 7000 miles last month and had some stalling problems sitting at lights along with an irradic idle. So I brought it in and they replaced the stepper motor along with a seal and some tubing (there was oil in these parts). Drove it home and an the way home it was still doing the same thing. So I brought it back the next day (last wednesday) They called me yesterday and said they looked at the service records and figured out the guy who had it before me didn't have the 6000 mile service done. So he seems to think that why my bike is running like shit. Is this possible? Can it stall and idle badly from missing a service? What is involved in a 6000 mile service?
Thanks,
 

·
Registered
Joined
·
4,658 Posts
Re: 6000 mile service...

Make sure they set the throttle position sensor and IACV voltage correctly, and checked the balance on the throttle body bores.
 

·
Registered
Joined
·
1,933 Posts
Re: 6000 mile service...

tripleniple said:
Long story short...
...They called me yesterday and said they looked at the service records and figured out the guy who had it before me didn't have the 6000 mile service done. So he seems to think that why my bike is running like shit. Is this possible? Can it stall and idle badly from missing a service? What is involved in a 6000 mile service?
Short answer - NO. The 6000 mile service is a simple check for stored Error Codes and balance the throttle bodies. Resetting ISCV voltage is not indicated in that service interval. MAYBE if there was an ECU error related to the erratic idle/stall, it could have been corrected then - but if they've correctly checked the diagnostics and found nothing, then it wasn't ever there to begin with.

I know a great shop to FIX your problem, but you'll have to ride it down here first...
 

·
Registered
Joined
·
6,851 Posts
Re: 6000 mile service...

obfuscate :beer:
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #7 ·
Re: 6000 mile service...

So I get a call today saying the bike is running perfectly. They synced the throttle bodies and done some other shit. OH and they NOTICED that there was a TORS tune loaded on my bike with a STOCK can. So now the correct MAP is loaded. I told the fucks a month ago to check the tune first to see if it correct. They instead found some oil in the stepper motor so I got a new one. So $500 later my bike is running right. :slap:
 

·
Registered
Joined
·
533 Posts
I'm not surprised the dealer did that. If your bike or car is running poorly, it's like an open book to fix anything that might be broken, regardless if it fixed the problem. I sometimes ask that if they are wrong will they at least reduce the price of the parts to cost. If they say no, it's the last time I go to that dealer. At least it is now fixed.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #10 ·
just an update for people with this same problem.
Even with the correct tune loaded it still would stall after warmed up.
So I had the CO level adjusted at the dealer (for free) and it fixed it.
Haven't had a problem since.
 
1 - 11 of 11 Posts
Top