Triumph Speed Triple Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter · #1 ·
My son's new (8,000 miles) Sprint broke its cam chain 3 weeks ago and he is still waiting for a fix. Dealer has 1 overworked mechanic and apparently Triumph did not have the part in the USA. The bike just quit running while going down the road.
Anyone heard of any other Triumph triples (1050's) breaking their cam chains??? Weird. no info so far. help appreciated.
 

·
Registered
Joined
·
4,658 Posts
Strange.

Is it at Bogart's?

MAKE SURE they check that the valves are OK. Many times when the came drive is broken, the pistons will hit the valves and bend or break them.

It doesn't take much in the way of contact to make the valve not seat correctly.
 

·
Registered
Joined
·
1,186 Posts
Th dealer should be ordering a new engine, not a cam chain. Devi is right, the S3 is an interference engine. That means that the valves and the piston occupy the same space, just at different times. If a cam chain breaks, the valves stop moving. The pistons don't. I can almost guarantee that the valves are bent, and the pistons are probably damaged too. It would probably take less time for the mechanic to put in a new motor than to fix the old one.
 

·
Registered
Joined
·
5 Posts
Cam guid broke, stalled motor

My '07 Speed Triple 1050 with around 30.000kms broke the chain guide. The oil pressure light flickered while I was doing 60km/h on the freeway and less than a minute later, the motor stalled.

The garage is still assessing the damage...

sux...
 
1 - 7 of 7 Posts
Top