Triumph Speed Triple Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
1,353 Posts
Discussion Starter · #1 ·
So, the big delay after finding out the 07 new exhaust has a catalyst put me in a pickle. I had pulled the header only to find I needed a half system that would take weeks longer... Now I have no bike to ride but all the parts to make it "work except a new header gasket.

Soo, I order a few sets of header gaskets and they just come in today.


I CAREFULLY mount everything back. Only to find that the exhaust is spitting out from between the header and engine... I let it cool, gentlly tightened a bit further (rinse and repeat... twice... to save some typing..) Now... I have gone as far as I am comfortable with on over tightening the bolts and still it spits a bit of exhaust out the front.

^%&^$#!!! Is it common to gunk up a simple job like mounting a header? I made sure the gaskets were well seated and slowly tighten the whole way around (evenly)

GRRRRR....
 

· Registered
Joined
·
1,353 Posts
Discussion Starter · #2 ·
fuck it, I am going to walk over to the bar and have quite a few drinks. Saturday is another day... Maybe I'l just get medieval with some high temp gasket goo..
 

· Registered
Joined
·
1,353 Posts
Discussion Starter · #5 ·
thanks DR. I actually torqued them down much more evenly and slowly than the manual asks for. I wonder if that might be a problem (but I dont know why)

Hi premier, I could hear it and also feel it when I got off and put my hand around the area of the exhaustports.. :(
 

· Registered
Joined
·
1,353 Posts
Discussion Starter · #7 ·
I got it in first try second attempt. I left the same gaskets in and just put a small bead of h-temp rtv around each gasket(think fettecnin noodle size)

I think my last failure had a lot to do with not really trying to seat the header by flexing the pipe back and forth while hand tightening ALL the bolts last time. I went through four iterations of really wiggling the pipe while tightening each bolt to hand tight. I found a lot more play than I thought I would have even the third iteration :)

Bike's back on the road until the Wolf 1/2 system shows up. I took it out for 100 miles today (fm 455 is a pretty good road between us 75 and i35)

Funny thing happened on my ride. My oil filter developed a pin hole leak, thank god nothing more dramatic... (and a pretty nasty dimple as if it got whacked right on the bottom. I have to guess I did this during all the exhaust work but there isnt a drop of oil near where I park/worked on it.. ??

Anyway, I'm out of action for the rest of the day and have an oil change scheduled for tomorrow :) Wolf sayd he'll be shipping my 1/2 system pretty quick so I am rubbing my grubby little hands thinking abou that extra 10-15 horsepower :)

C-Dub
 

· Registered
Joined
·
1,353 Posts
Discussion Starter · #15 ·
Just as an update, my Trident cans came in but still waiting on the pipes from Peter. It ought to ship this week. I THINK by the end of next week I'll have a full system attached with closer to 130 HP than 110... :)

I have put an additional 150 miles on the bike and it runs great. I am looking closely at the suspension now. Seems the front end dives VERY fast. (or maybe its just my squid braking abilities..)

C-Dub
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top