Triumph Speed Triple Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
So my fuel light has been coming on and going off at really random times, with no regard to actual fuel level. It'll come on 10 minutes after I've filled the tank, but not come on when it's totally empty, and I decided to tear into it and see what's up. I removed the pump/filter assembly and look around, and this is what I found...
Motor vehicle Automotive tire Vehicle Automotive exterior Automotive wheel system


Upon closer inspection of the fuel level sender I noticed corrosion and one wire that was barely hanging on...

Guitar accessory String instrument accessory Musical instrument accessory Musical instrument Sewing


Gesture Finger Musical instrument accessory Thumb Nail


I cut the wire about 3mm back from the end of the insulation, stripped to fresh copper, cleaned it with acid, removed the soldered bits from the sender switch, and soldered the fresh wire ends to the switch. I tested it out and it seems to be working as it should, comes on at the right time, and only at the right time. my theory is that the connection was so loose that when the gas would slosh around it would move the wires in and out of making a decent connection. I'm wondering if some of the other issues people have with the fuel level light might be traced back to bad solder joints and corroded wires.

Automotive tire Motor vehicle Gas Auto part Metal
 

· Registered
Joined
·
410 Posts
good find my light is been on for over a year now and although its not a big concern to get it off since i always pay attention to my gas level and mileage its certainly annoying to see that light on my dash, I will have to tear it down and give the pump a service sometime soon. Not really looking forward to tear down since i know there is several items to give maintenance. this means i will have to put her on the stand for a couple weeks.
 

· Registered
Joined
·
563 Posts
Same type deal here, my light has always stayed on regardless of level. Wires looked to be hooked up fine inside the tank. Level sensor inside the tank maybe needs to be replaced? Hasn't really been much of a priority to fix, always have gone off of miles ridden, Issues that have stranded me have taken up most of my time. Nevertheless, I did run out of gas a mile past a service station awhile back. Pushing absolutely sucks, so maybe it's time to have more of a look see.
 

· Registered
Joined
·
410 Posts
Joe, my light its been on all the time for about 2 years ... I do have TOD loaded on my 05, I read somewhere in one of your post that this might be caused due to the TOD map being from a 08-10 model so i never thought it had to do with anything other than the map being from a different model (reason it never bother me) since i love the TOD. and the bike runs fantastic. I will look into mstork33 fix when i get into the tank to service the filter.
 

· Registered
Joined
·
12,429 Posts
If you run the steel tank TOD in a plastic tank, or plastic in steel, it will cause the fuel light to work in reverse, so light on when full, and light goes out when low/empty

plastic tank light will stay on if there is a break in the circuit
steel tank light will stay off if there is a break in the circuit
 

· Registered
Joined
·
174 Posts
Discussion Starter · #9 ·
My wires were corroded pretty bad, but there was just enough of a connection that I think the fuel sloshing around would wiggle the remaining strands of wire just enough to make the light come on/go out. I'm curious to see if anyone has similar luck with this fix, or benefits from re-soldering the wires. I made it a point to tin the wires right up to the insulation to minimize copper exposure, hopefully preventing more corrosion in the future. I also did this when it was 3 days of rain so I didn't miss out on any riding.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top