Triumph Speed Triple Forums banner
1 - 14 of 14 Posts
G

·
Discussion Starter · #1 ·
My bike is still at the dealer (06S3), for its first service. I complained about the chain making noises like it was slack. The dealer claims the the chain will tighten then loosen when taken on the road for a test ride. Now waiting on Triumph for a warranty claim. I remember reading on Rat that somebody else had the same issues? I cannot figure out how this can happen, any thoughts?
 

·
Registered
Joined
·
4,658 Posts
If everything is adjusted correctly, the chain tensioner needs to be checked.
 

·
Registered
Joined
·
6,851 Posts
 
G

·
Discussion Starter · #6 ·
dealer called, claimed the rear sprocket was part of a bad batch installed on quite a few 06's. stated that the sprocket is out of round??????????? will take a week to steamship a new sprocket from england?????????? :-\
 

·
Registered
Joined
·
6,851 Posts
aftermarket??? regear???
 

·
Registered
Joined
·
2,293 Posts
aftermarket??? regear???
Is it worth the hassle to have the dealer fix it, as opposed to getting a Vortex gear at Cycle Gear.
 
G

·
Discussion Starter · #10 ·
Still waiting on sprocket, bike has been in shop for 10 days. The reason I am keeping it at the dealer is twofold, it is a warranty item and I do not think this warranty repair is correct. I feel that once replaced the dealer will discover that the bike will continue to have a slack chain. I have never heard of a out-of-round sprocket before, I think it is the chain tensioner that is the problem.
 

·
Registered
Joined
·
244 Posts
Have you mentioned this to the dealer?
Just in case they don't know about this possibility??

:afro:
 
G

·
Discussion Starter · #13 ·
Sorry but we can end this thread. It was a out-of-round sprocket. Replaced by dealer after a 2.5 week delay.
 

·
Registered
Joined
·
2,989 Posts
Good to hear you got it taken care of. Dealer's seem to have a hard time stocking normal wear and tear parts for some reason. Mine's really bad.
 
1 - 14 of 14 Posts
Top