Triumph Speed Triple Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
Just picked up an 08 Speed triple and after riding for a few hundred miles, I noticed that some fluid was leaking out of the rear shock. The liquid seems to have come from where the hose from the 'cylinder' that's not part of the shock (sorry don't know the proper name) meets the top of the shock. I tightened the nut a bit yesterday but it did not seem like it needed that. Has anyone ever had this problem? What causes this and does it require replacement?

After some digging, It might not be the shock leaking as the fluid seems to be corrosive... fekkk

Thanks in advance!
 

·
Registered
Joined
·
2,318 Posts
This usually shows up on new bikes.
It seems to be the crap that Triumph puts on the bikes when they ship them to prevent corrosion.
When the bike warms up it liquidises and leaks onto the shock.
I can't remember where from(upper shock mount?).
The PO must not have cleaned it.
It should be a waxy white substance.
Prepsol/waxand grease remover should clean it right up.

AA
 

·
Registered
Joined
·
32,017 Posts
The fluid inside the shock (any shock) is an oil, which shouldn't evaporate and leave any kind of whitish deposit and is certainly not corrosive. This leads me to believe it's something else leaking onto the shock. The 08 should have a sealed battery, so that's unlikely unless the PO put an incorrect replacement in there. AA may be right, but I couldn't say. I've never had that problem. My best guess is it is coolant from the reservoir like Marka said. They do tend to overflow if they are filled up to what appears to be the correct level. That's common to all these bikes. And you never know what someone has been putting in their coolant.
 
1 - 11 of 11 Posts
Top