Triumph Speed Triple Forums banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
FIRST OFF GREAT SITE. HEY NEW GUY HERE W/ A PROBLEM I THINK. 2006 TRIPLE, BUDDY OF MINE WANTS TO HEAR THE PIPES I JUST INSTALLED SO I LET HIM HEAR THEM. BLIP THE THROTTLE AND NOW IT WON'T RUN. I UNPLUGGED THE BATT. TO MAYBE RESET THE COMPUTER WAITED A LITTLE WHILE AND STARTED IT AGIN AND IT IDLE FINE TOUCH THE THROTTLE AND IT CUT OFF AND NOW WILL NOT START BACK. ANY INFO WOULD VERY HELPFUL. THANKS
 

·
Registered
Joined
·
4,658 Posts
Definately check you plugs. The plug wells tend to allow moisture to build up and corrode the plug's grounding surface.

Rumor is that Triumph has, or is working on, a better boot around the coils to seal the plugwell better. I am checking into this.
 

·
Registered
Joined
·
2,293 Posts
The Speed Triple is very sensitive to throttle goosing. I've read a couple dozen posts by people who just wanted to 'show' friends what the bike sounds like, and ended up fouling the plugs.

You've got to take the tank off (3 screws, a nut and bolt, a wire plug and three hoses) and take the air box off (two bolts, a screw and three more hoses. Take the plugs out, one by one, clean them inside and out, check the gap and re-install.

If you want to show off the pipes, run the engine up smoothly, or do a ride-by. If you're sitting at a light, you don't have to do that Harley thing and goose the throttle every thirty seconds - it runs fine at idle.
 

·
Registered
Joined
·
17 Posts
CORNBREAD said:
FIRST OFF GREAT SITE. HEY NEW GUY HERE W/ A PROBLEM I THINK. 2006 TRIPLE, BUDDY OF MINE WANTS TO HEAR THE PIPES I JUST INSTALLED SO I LET HIM HEAR THEM. BLIP THE THROTTLE AND NOW IT WON'T RUN. I UNPLUGGED THE BATT. TO MAYBE RESET THE COMPUTER WAITED A LITTLE WHILE AND STARTED IT AGIN AND IT IDLE FINE TOUCH THE THROTTLE AND IT CUT OFF AND NOW WILL NOT START BACK. ANY INFO WOULD VERY HELPFUL. THANKS
Why are you yellin at us. Not all of us are DEEF!!!!


(hehehehehe) :jerkoff: :smiley-asskiss: :twofinger:
 
1 - 8 of 8 Posts
Top