Triumph Speed Triple Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all and thanks for bothering to read this. First: I have a 2018 Speed Triple RS, complete with QS. Love the bike. 40k kilometers driven. No issues like this before. Valve service is close.
Some background info: 3 weeks ago I had a engine stop, failed to start and battery was misbehaving. Found out that i had gotten some water in the fuel tank. Used a chemical cleaner and got it running. I have had battery issues since. Fail to start and battery so low that the bike settings, like QS was automatically disabled.

Some days ago i was out driving, pulled hard on 2nd- 3rd (perfect) and then 4th, but engine "twitched" for a micro second, then pulled as normal. This happens again and again. Only in the 4th gear. Engine and output are as should in all other gears.
I have tried turning of QS and TC, and no difference.
I replaced battery, was needed anyway, so why not. It seemed better at first, which means it didnt "twitch" at about 4k rpm accelerating, but happened again when i pulled harder on the highway. So it seems as if it only occurs when going full throttle.
It seems to happen "easier" in sport mapping, cant be totally sure,
I have no skills, and to be honest it actually feels pretty much the same as if i mistakenly touch the clutch or gearliever with QS engaged. But i am sure that i don`t.
I might not have been able to remove all water, but even though, it is hard to understand why that only would affect 4th gear. But will not argue against that as an optional reason.
I will take the bike to the shop, but would really appreciate some input or suggestions first. No warranty on this bike.
 

·
Registered
Joined
·
4,547 Posts
Really doubt the water has anything to do with your problems. Assuming you have ethanol blend fuels where you are they will clean up small amounts of water without any extra chemicals. Seems to me that something is reacting to engine vibration that is only happening in 4 gear. I would double check the mounting and electrical connections for things like the kickstand switch, kill switch, ignition switch, etc. that can kill the engine. Also look for any bare wires. Good luck, this kind of thing can be a real PITA to find. Don't count on much help from the dealership. If they can pull an error code they might be able to help but you didn't say that you have a check engine light so probably no code stored. Most dealers can't trouble shoot to save their lives.
 

·
Registered
Joined
·
6,838 Posts
Could it be as simple as a clutch cable adjustment? I feel it’d be happening throughout the gears, but worth a look.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I have changed the battery. Cleaned the fuel tank. Lubricated all wires. Running out of options.. I will try to adjust clutch cable, even though I can’t see how that could affect one gear only.
 
1 - 4 of 4 Posts
Top