Triumph Speed Triple Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
972 Posts
Discussion Starter · #1 ·
So here is the problem...

During Idle In neutral I am usually around 1200 - 1350 rpms constant.

When I throtle up passed 2500 rpms and release the throtle my rpms drop to around 800 then go back up to 1200 - 1350. One time my bike died....is this normal?

I have a Zard slip-on with TORS tune and PCommander. This happens when I run the zero map too.
 

·
Registered
Joined
·
1,186 Posts
Have a dealer load the arrow tune, it runs much better. I know this firsthand. The tors tune is too rich in the midrange. Your bike is probably loading up with fuel, then having to burn it all off when the butterflies close. You might check your plugs, I bet they're black/sooty or even wet.
 

·
Registered
Joined
·
2,326 Posts
Lighten upl Gov .
While you want and should get tech questions answered, attitudes like that is why a lot of people are on this site.

AA
 

·
Registered
Joined
·
972 Posts
Discussion Starter · #6 ·
AA, the troubleshooting section, IMHO is a serious section. While Limey's response was actually kind of funny, my response was also intended to be funny...I don't think Limey cared or he would have contacted me and sorted it out.

Actually I am rather amused that you are fighting for his honor....Limey!!! you got a fan... :gayaway:
 

·
Registered
Joined
·
2,326 Posts
Nah, the only thing I fight for is free speech an ;Dd the last piece of pizza. :tongue2:

AA
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top